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1 Introduction to Foxit PDF SDK 

1.1 Foxit PDF SDK 

Foxit PDF SDK provides high-performance libraries to help any software developer add robust PDF 

functionality to their enterprise, mobile and cloud applications across all platforms (includes 

Windows, Mac, Linux, Web, Android, iOS, and UWP), using the most popular development languages 

and environments. 

Application developers who use Foxit PDF SDK can leverage Foxit’s powerful, standard-compliant 

PDF technology to securely display, create, edit, annotate, format, organize, print, share, secure, 

search documents as well as to fill PDF forms. Additionally, Foxit PDF SDK includes a built-in, 

embeddable PDF Viewer, making the development process easier and faster. For more detailed 

information, please visit the website https://developers.foxitsoftware.com/pdf-sdk/. 

In this guide, we focus on the introduction of Foxit PDF SDK for UWP platform. 

1.2 Foxit PDF SDK for UWP 

Have you ever worried about the complexity of the PDF specification? Or have you ever felt lost 

when asked to build a full-featured PDF app within a limited time-frame? If your answer is "Yes", 

then congratulations! You have just found the best solution in the industry for rapidly integrating 

PDF functionality into your apps.  

Foxit PDF SDK for UWP focuses on helping developers easily integrate powerful Foxit PDF 

technology into their own apps. With this SDK, even developers with a limited knowledge of PDF can 

quickly build a professional PDF viewer with just a few lines of code on Universal Windows Platform 

(UWP) for Windows 10. 

1.2.1 Why Foxit PDF SDK for UWP is your choice 

Foxit is a leading software provider of solutions for reading, editing, creating, organizing, and 

securing PDF documents. Foxit PDF SDK libraries have been used in many of today’s leading apps, 

and they are proven, robust, and battle-tested to provide the quality, performance, and features 

that the industry’s largest apps demand.  

https://developers.foxitsoftware.com/pdf-sdk/?nabe=5502951895597056%3A1&nabr=10
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Foxit PDF SDK for UWP provides quick PDF viewing and manipulation support for Windows 10 

Universal Windows Platform. Customers choose it for the following reasons: 

• Easy to integrate 

Developers can seamlessly integrate the SDK into their own apps with just a few lines of code.  

• Perfectly designed 

Foxit PDF SDK for UWP is designed with a simple, clean, and friendly style, which provides the best 

user experience. 

• Flexible customization 

Foxit PDF SDK for UWP provides the source code for the user interface which lets the developers 

have full control of the functionality and appearance of their apps.  

• Robust performance on mobile platforms 

Foxit PDF SDK for UWP provides an OOM (out-of-memory) recovery mechanism to ensure the app 

has high robust performance when running the app on a mobile device which offers limited 

memory.  

• Powered by Foxit’s high fidelity rendering PDF engine 

The core technology of the SDK is based on Foxit’s PDF engine, which is trusted by a large number of 

the world’s largest and well-known companies. Foxit’s powerful engine makes the app fast on 

parsing, rendering, and makes document viewing consistent on a variety of devices. 

• Premium World-side Support 

Foxit offers premium support for its developer products because when you are developing mission 

critical products you need the best support. Foxit has one of the PDF industry’s largest team of 

support engineers. Updates are released on a regular basis to improve user experience by adding 

new features and enhancements. 

1.2.2 Main Frame of Foxit PDF SDK for UWP  

Foxit PDF SDK for UWP consists of three elements as shown in the following picture. This structure is 

shared between all mobile platform versions of Foxit PDF SDK, which makes it easier to integrate 

and support multiple mobile operating systems and frameworks in your apps. 
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The three elements of Foxit PDF SDK for Android, iOS and UWP  

• PDF Core API 

The PDF Core API is the heart of this SDK and is built on Foxit’s powerful underlying technology. It 

provides the functionality for basic PDF operation features, and is utilized by the PDF View Control 

and UI Extensions project, which ensures the apps can achieve high performance and efficiency. The 

Core API can be used independently for document rendering, analysis, text extraction, text search, 

form filling, annotation creation and manipulation and much more.  

• PDF View Control  

The PDF View Control is a utility class that provides the functionality for developers to interact with 

rendering PDF documents per their requirements. With Foxit’s renowned and widely used PDF 

rendering technology at its core, the View Control provides fast and high-quality rendering, zooming, 

scrolling and page navigation features. The View Control derives from platform related viewer 

classes and allows for extension to accommodate specific user needs.  

• UI Extensions Project 

The UI Extensions Project is an open source project that provides a customizable user interface with 

built-in support for text selection, markup annotation, outline navigation, form filling, text reflow, 

and document editing. These features in the UI Extensions are implemented using the PDF Core API 

and PDF View Control. Developers can utilize these ready-to-use UI implementations to build a PDF 
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viewer quickly with the added benefit of complete flexibility and control to customize the UI design 

as desired. 

1.2.3 Key Features of Foxit PDF SDK for UWP 

Foxit PDF SDK for UWP has several main features which help app developers quickly implement the 

functions that they really need and reduce the development cost.   

Features  

PDF Document Open and close files, set and get metadata. 

PDF Page Parse, render, read, and edit PDF pages. 

Render Graphics engine created on a bitmap for platform graphics device. 

Reflow Rearrange page content. 

Text Select Search text in a PDF document 

Text Search Search text in a PDF document. 

Bookmark(Outline) Directly locate and link to point of interest within a document. 

Annotation Create, edit and remove annotations. 

Form 
Fill form with JavaScript support, export and import form data by 

XFDF/FDF/XML file. 

Out of Memory Recover from an OOM condition. 

Note Outline is the technical term used in the PDF specification for what is commonly known as 

bookmarks in traditional desktop PDF viewers. Reading bookmarks are commonly used on mobile and 

tablet PDF viewers to mark progress and interesting passages as users read but are not technically outline 

and are stored at app level rather than within the PDF itself. 

1.3 Evaluation 

Foxit PDF SDK allows users to download trial version to evaluate SDK. The trial version has no 

difference from the standard licensed version except for the free trial limitation and the trial 

watermarks in the generated pages. After the evaluation period expires, customers should contact 

the Foxit sales team and purchase licenses to continue using Foxit PDF SDK. 
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1.4 License 

Developers should purchase licenses to use Foxit PDF SDK in their solutions. Licenses grant 

developers permission to release their apps which utilize Foxit PDF SDK. However, users are 

prohibited to distribute any documents, sample code, or source code in the released package of 

Foxit PDF SDK to any third party without written permission from Foxit Software Incorporated. 

1.5 About this Guide 

This guide is intended for the developers who need to integrate Foxit PDF SDK for UWP into their 

own apps for both PC/tablet and Windows Phone. It aims at introducing the following sections: 

• Section 1: gives an introduction of Foxit PDF SDK, especially for UWP SDK. 

• Section 2: illustrates the package structure, running demo. 

• Section 3: describes how to quickly create a full-featured PDF Reader. 

• Section 4: provides support information. 
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2 Getting Started 

It is very easy to setup Foxit PDF SDK and see it in action! It takes just a few minutes and we will 

show you how to integrate it with Universal Windows Platform (UWP) apps on Windows 10. The 

following sections introduce the structure of the installation package, how to run a demo, and how 

to create your own project. 

2.1 System Requirements 

Windows 10 Universal Apps: 

Windows 10 

Recommend to install Visual Studio 2017 (with Universal Windows App Development Tools)  

The release package includes arm, x64 and x86 dynamic link libraries for Windows 10 Universal app. 

2.2 What is in the Package 

Download the "foxitpdfsdk_7_0_2_uwp.zip" package, and extract it to a new directory like 

"foxitpdfsdk_7_0_2_uwp" as shown in Figure 2-1. The package contains: 

docs: A folder containing API references, developer guide. 

libs: A folder containing license files, FoxitRDK.vsix, and UI 

Extensions project. 

samples: A folder containing UWP sample projects. 

FoxitSDK.sln A solution file for the demos. 

legal.txt:  Legal and copyright information. 

release_notes.txt: Release information. 

NOTE: the highlighted rectangle in the figure is just the version of Foxit PDF SDK for UWP. Here the SDK 

version is 7.0.2, so it shows 7_0_2 in the package name. Other highlighted rectangles in other figures have 

the same meaning in this guide. 
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Figure 2-1 

In the "libs" folder as shown in Figure 2-2, there are items that make up the core components of 

Foxit PDF SDK for UWP. 

 

Figure 2-2 

▪ FoxitRDK.vsix - The extension package. 

▪ UIExtensions project - It is an open source project that contains the UI implementations for 

the basic UI of app and the ready-to-use feature module UI, which can help developers 

rapidly embed a fully functional PDF reader into their UWP app. Of course, developers are 

not forced to use the default UI, they can freely customize and design the UI for their specific 

apps through the "UIExtensions" project. 

At this point you should just be getting a feel for what Foxit PDF SDK package looks like, we’re going 

to cover everything in detail in a bit. 

2.3 How to run a demo 

Download and install Visual Studio IDE (https://www.visualstudio.com/). 

Note: In this guide, we will run the demos in Visual Studio 2017. This guide does not cover the installation 

of Visual Studio. You can refer to Visual Studio’s developer site if you haven’t installed it already. 

https://www.visualstudio.com/
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Foxit PDF SDK for Universal Windows Platform (UWP) on Windows 10 provides two useful C++ 

demos and one C# demo for developers to learn how to call the SDK as shown in Figure 2-3. 

 

Figure 2-3 

2.3.1 Install Foxit PDF SDK extension 

To run the demos in Visual Studio 2017, Foxit PDF SDK extension should be installed at first. 

Double-click FoxitRDK.vsix in the "lib" folder, click on Install in the "VSIX Installer" dialog to allow 

Foxit PDF SDK extension to be installed (see Figure 2-4). Note: Before installing Foxit PDF SDK 

extension, please close Visual Studio. 

 

Figure 2-4 
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Note: If you already have a version of Foxit PDF SDK for UWP installed, you might get an error message 

stating "This extension is already installed to all applicable products." In this case, please uninstall 

the old version in Visual Studio 2017 by following the steps:  

a) Open menu "Tools -> Extensions and Updates….", under the menu Installed -> All, you should be 

able to find "FoxitRDK" extension. Select it and click Uninstall.  

b) Close Visual Studio, then the "VSIX Installer" dialog will pop up as shown in Figure 2-5. Click Modify to 

uninstall the extension. 

 

Figure 2-5 

2.3.2 Function demo 

The function demo coded by C++ is provided to show how to use Foxit PDF SDK for UWP to realize 

some specific features related to PDF with PDF core API. This demo includes the following features: 

• pdf2txt: extract text from a PDF document to a TXT file. 

• outline: edit outline (aka bookmark) appearances and titles.  

• annotation: add annotations to a PDF page. 

• docinfo: export document information of a PDF to a TXT file. 

• render: render a specified page to Bitmap. 

To run it in Visual Studio 2017, follow the steps below: (in this guide, we use the local machine with 

x86 as an example to run the demos)  
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a) Refer to "Install Foxit PDF SDK extension" to install SDK extension.  

b) Open FoxitSDK.sln in Visual Studio 2017. Then check whether Foxit PDF SDK extension has 

already been installed successfully in Visual Studio. Click on Tools -> Extensions and 

Updates… in the menu of Visual Studio, you will see the installed extension as shown in 

Figure 2-6. 

 

Figure 2-6 

Note: If you Open FoxitSDK.sln in Visual Studio 2015 to run the demos, you should change the 

Platform Toolset to Visual Studio 2015 (V140). Right-click the demo project in the solution 

explorer, select Properties. In the Property Pages dialog, select General -> Platform Toolset, and 

choose Visual Studio 2015 (V140). (See Figure 2-7) 
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Figure 2-7 

c) Change the build architecture of the project. Click on Build -> Configuration Manager and 

choose x86 for "Active solution platform" as shown in Figure 2-8. 

 

Figure 2-8 

Note: There are three active solution platforms: x86, x64, and arm. You should choose the proper 

platform for the build architecture according to the system you used to run the project. For 

example, if you will run the demo in an arm device, please choose ARM for "Active solution 

platform". 
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d) Right-click the project "FunctionDemo" and select "Set as StartUp Project".  

e) Click on Local Machine as shown in Figure 2-9 to build and run the demo. The screenshot of 

the demo is shown in Figure 2-10. 

 

Figure 2-9 

 

Figure 2-10 

f) Click the feature buttons in the above picture to perform the corresponding actions. For 

example, click "pdf2txt", and then a message box will be popped up as shown in Figure 2-11. 
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It shows where the text file was saved to. Just run the demo and try the features. 

 

Figure 2-11 

2.3.3 Complete PDF viewer demo 

The complete PDF viewer demo coded by C++ demonstrates how to use Foxit PDF SDK for UWP to 

realize a completely full-featured PDF viewer which is almost ready-to-use as a real world mobile 

PDF reader. This demo utilizes all of the features and built-in UI implementations which are provided 

in Foxit PDF SDK.  

To run the demo in Visual Studio 2017, please refer to the setup steps outlined in the Function 

demo. 

Right-click the project "CompletePDFViewer" and select "Set as StartUp Project". Press F5 to build 

and run the demo. After building the demo successfully, on the start screen, it lists the 

"developer_guide_uwp.pdf" document (see Figure 2-12). 
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Figure 2-12 

Click the "developer_guide_uwp.pdf" document, and then it will be opened and displayed as shown 

in Figure 2-13.  

 

Figure 2-13 

This demo realizes a completely full-featured PDF viewer, please feel free to run it and try it. 
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For example, it provides the page thumbnail feature. You can click  at the top bar, choose the 

Thumbnail as shown in Figure 2-14, and then the thumbnail of the document will be displayed as 

shown in Figure 2-15. 

 

Figure 2-14 

 

Figure 2-15 
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2.3.4 PDFViewer demo 

The PDFViewer demo is similar to the Complete PDF viewer demo. It demonstrates how to use C# to 

implement a completely full-featured PDF viewer. 

To run the demo in Visual Studio 2017, please refer to the setup steps outlined in the Function 

demo. 

Right-click the project "PDFViewer" and select "Set as StartUp Project". Press F5 to build and run the 

demo. After building the demo successfully, on the start screen, Click the button "Open a PDF" (See 

Figure 2-16) to select a PDF document. For example, select the "developer_guide_uwp.pdf" in the 

"docs" folder of the download package, and then the document will be opened and displayed as 

shown in Figure 2-17. You can feel free to experience the full-featured PDF viewer. 

 

Figure 2-16 
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Figure 2-17 
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3 Rapidly building a full-featured PDF Reader  

Foxit PDF SDK for UWP wrapped all of the UI implementations including the basic UI for app and 

ready-to-use UI feature modules to UI Extensions project, so that developers can easily and rapidly 

build a full-featured PDF Reader with just a few lines of code. This section will help you to quickly get 

started with using Foxit PDF SDK for UWP to make a full-featured PDF Reader app in C++ and C# 

with step-by-step instructions provided. It includes the following steps: 

3.1 Make a UWP app in C++ with Foxit PDF SDK for UWP 

This section will help you to quickly make a UWP app in C++ using Foxit PDF SDK. It includes 

the following steps: 

• Create a new UWP app in C++ Using Foxit PDF SDK for UWP 

• Initialize Foxit PDF SDK 

• Display a PDF document Using PDFViewCtrl 

• Build a full-featured PDF Reader Using UI Extensions Project 

3.1.1 Create a new UWP app in C++ Using Foxit PDF SDK for UWP 

In this guide, we will create a new UWP project in Visual Studio 2017, and use local machine with x86 

as an example to run the project. 

1) Create a new project in Visual Studio 2017. 

Open Visual Studio 2017, choose File -> New -> Project… to start the New Project wizard. 

Create a new Windows Universal project called "PDFReader". Please make sure to choose Visual 

C++ and a blank app (See Figure 3-1).  
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Figure 3-1 

2) Add FoxitRDK extension to References. 

In order to use FoxitRDK extension in the project, you must first add a reference to it. In the 

Solution Explorer, right-click the References node and select Add Reference… as shown in 

Figure 3-2. 

Note: If you have not installed FoxitRDK.vsix extension, please refer to "Install Foxit PDF SDK 

extension" to install it at first. 
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Figure 3-2 

In the Add Reference dialog, select Universal Windows -> Extensions tab, check the box next to 

"FoxitRDK", and then click OK. It is shown in Figure 3-3.  

 

Figure 3-3 

3) Change the build architecture of the project. 

Click on Build -> Configuration Manager and select x86 for "Active solution platform" as 

shown in Figure 3-4. 
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Figure 3-4 

Note: There are three active solution platforms: x86, x64, and arm. You should choose the proper 

platform for the build architecture according to the system you used to run the project. For example, 

if you will run the demo in an arm device, please choose ARM for "Active solution platform". 

3.1.2 Initialize Foxit PDF SDK 

It is necessary for apps to initialize and unlock Foxit PDF SDK using a license before calling any APIs. 

The function foxit::common::Library::Initialize(sn, key) is provided to initialize Foxit PDF SDK. The 

trial license files can be found in the "libs" folder of the download package. After the evaluation 

period expires, you should purchase an official license to continue using it. Finish the initialization at 

the end of the App::OnLaunched function within the App.xaml.cpp file. 

// Initialize Foxit PDF SDK. 

String^ sn = " "; 

String^ key = " "; 

foxit::common::ErrorCode ret = foxit::common::Library::Initialize(sn, key); 

if (ret != foxit::common::ErrorCode::e_ErrSuccess) 

   return; 

Note The value of "sn" can be found in the "rdk_sn.txt" (the string after "SN=") and the value of "key" can 

be found in the "rdk_key.txt" (the string after "Sign=").  

3.1.3 Display a PDF document Using PDFViewCtrl 

So far, we have added FoxitRDK extension as a reference and finished the initialization of the Foxit 

PDF SDK. Now, let’s start displaying a PDF document using PDFViewCtrl with just a few lines of code. 
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1) Add a PDFViewCtrl to display a PDF document. 

Open up "MainPage.xaml", update the whole file as follows: 

<Page 

    x:Class="PDFReader.MainPage" 

    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation" 

    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml" 

    xmlns:local="using:PDFReader" 

    xmlns:rdkcontrol="using:foxit.rdk" 

    xmlns:d="http://schemas.microsoft.com/expression/blend/2008" 

    xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006" 

    mc:Ignorable="d"> 

 

    <Grid Background="{ThemeResource ApplicationPageBackgroundThemeBrush}"> 

        <UserControl x:Name="HostContent" Grid.Row="0"> 

            <!--Place a PDF View control.--> 

            <rdkcontrol:PDFViewCtrl x:Name="PDFViewControl"> 

                <Grid> 

                    <!--Place a button on the left-top of the view control.--> 

                    <Button Content="Open File" FontSize="20" HorizontalAlignment="Left"  

                            VerticalAlignment="Top" Click="OpenFileButton_Click"/> 

                </Grid> 

            </rdkcontrol:PDFViewCtrl> 

        </UserControl> 

 

        <!--Place a holder for uiextension flyout placement.--> 

        <Grid x:Name="FlyoutGird" Grid.Column="1" Grid.RowSpan="2" MaxWidth="300"> 

        </Grid> 

    </Grid> 

</Page> 

Here, we add a button with a click event "OpenFileButton_Click" to open a PDF document, and add 

a PDFViewCtrl to display the PDF document. 

2) Declare and implement "OpenFileButton_Click" function. 

Open up "MainPage.xaml.h", declare the "OpenFileButton_Click" function as follows: 

#pragma once 

 

#include "MainPage.g.h" 

 

namespace PDFReader 

{ 

 /// <summary> 

 /// An empty page that can be used on its own or navigated to within a Frame. 

 /// </summary> 

 public ref class MainPage sealed 
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 { 

 public: 

  MainPage(); 

 

 private: 

  void OpenFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e); 

 

 }; 

} 

Open up "MainPage.xaml.cpp", implement the "OpenFileButton_Click" function as follows: 

void PDFReader::MainPage::OpenFileButton_Click(Platform::Object^ sender, 

Windows::UI::Xaml::RoutedEventArgs^ e) 

{ 

 // Select a PDF file from a file selection dialog.   

 Windows::Storage::Pickers::FileOpenPicker^ openPicker = ref new 

Windows::Storage::Pickers::FileOpenPicker(); 

 openPicker->ViewMode = Windows::Storage::Pickers::PickerViewMode::Thumbnail; 

 openPicker->SuggestedStartLocation = 

Windows::Storage::Pickers::PickerLocationId::DocumentsLibrary; 

 openPicker->FileTypeFilter->Append(".pdf"); 

 

 concurrency::create_task(openPicker->PickSingleFileAsync()) 

  .then([this](Windows::Storage::StorageFile^ file) 

 { 

  if (file) 

  { 

   PDFViewControl->OpenDocAsync(file, ""); 

  } 

 }); 

} 

Inside the "OpenFileButton_Click" function, get a PDF document from the file picker, and call 

OpenDocAsync interface to display the PDF document.  

3) Click on Local Machine to build and run the project. The screenshot of the project is shown in 

Figure 3-5. 
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Figure 3-5 

Click on Open File to choose and open a PDF document. For example, we choose the 

"sample.pdf" in the "Samples\FunctionDemo\TestFiles" folder, and then it will be displayed as 

shown in Figure 3-6. 

 

Figure 3-6 

Note: If you cannot open PDF files, you should add File Type Associations Declarations in the 

"Package.appxmanifest" file. 
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Double click Package.appxmanifest in the project, find Declarations, and add a File Type 

Associations as shown in Figure 3-7. 

 

Figure 3-7 

Now, we have finished displaying a PDF document using PDFViewCtrl. At that time, the PDFReader 

app is just a very basic PDF document viewer. You can only view or zoom in/out the PDF document. 

If you want to build a full-featured PDF Reader app, just follow the steps in the next section. 

3.1.4 Build a full-featured PDF Reader Using UI Extensions Project 

The UI Extensions project contains all of the UI implementations including the basic UI for app and 

the feature modules UI. Hence, building a full-featured PDF Reader is getting simpler and easier. 

Let's try it just now. 

1) Add "UIExtensions" project in the "libs" folder of the download package to the solution. 

In the solution explorer, right-click on the PDFReader solution and select Add -> Existing 

Project…, navigate to the folder where the "foxitpdfsdk_7_0_2_uwp.zip" was unzipped, open the 

"UIExtensions" folder in the "libs" folder, then select "UIExtensions.vcxproj". (See Figure 3-8 and 

Figure 3-9) 
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Figure 3-8 

 

Figure 3-9 

After adding the "UIExtensions" project, the solution should look like Figure 3-10. 
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Figure 3-10 

2) Add "foxit.rdk.uiextensions" project as a reference used by PDFReader. Do this in a similar way 

to how we added FoxitRDK extension. 

In the Solution Explorer, in the PDFReader project, right-click the References node and select 

Add Reference…. In the Add Reference dialog, select Projects -> Solution tab, find 

"foxit.rdk.uiextensions" in the list, check the box next to it and then click OK. (See Figure 3-11) 
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Figure 3-11 

3) Build "foxit.rdk.uiextensions" project. Right-click the project, select Build. 

4) Add SDK resources to the project.  

Copy the Resources folder from "libs\UIExtensions" folder of Foxit PDF SDK for UWP package to 

"PDFReader\PDFReader" folder. 

In the Solution Explorer, click the icon (See Figure 3-12) to show all files. Then, expand the 

Resources folder, right-click on the items that are marked in red, and choose "Include In 

Project" to include the resource files to the project (For example, see Figure 3-13). 
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Figure 3-12 
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Figure 3-13 

After including all the resource items, the PDFReader project should look like Figure 3-14. 
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Figure 3-14 

5) Instantiate a UIExtensionsManager object and set it to PDFViewCtrl. 

Open up "MainPage.xaml.h", declare a UIExtensionsManager object as follows: 

private: 

foxit::rdk::uiextensions::UIExtensionsManager^ m_uiextensions; 

Open up "MainPage.xaml.cpp", instantiate the UIExtensionsManager object and set it to 

PDFViewCtrl in the constructor of MainPage: 

MainPage::MainPage() 

{ 

 InitializeComponent(); 

 

 m_uiextensions = ref new foxit::rdk::uiextensions::UIExtensionsManager(PDFViewControl); 

 

 // Associate the flyout placement of uiextensions with MainPage layout. 

 m_uiextensions->SetFlyoutPlacement(FlyoutGird); 

 

 // Set the uiextensions instance to PDF view control. 

 PDFViewControl->ExtensionsManager = m_uiextensions; 

} 
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6) Click on Local Machine to build and run the project.  

Click on Open File to choose and open a PDF document. For example, we choose the 

"sample.pdf" in the "Samples\FunctionDemo\TestFiles" folder, and then it will be displayed as 

shown in Figure 3-15. 

 

Figure 3-15 

Now, a full-featured PDF Reader app which is similar to the Complete PDF viewer demo has been 

built. Feel free to try the features. 

The "foxit.rdk.uiextensions" project has implemented the basic UI for app and the feature module 

UI, so that if you want to customize the UI for styling the appearance as desired, you can change the 

code in the UIExtensions project directly.  

Complete Program 

This section shows the whole update of "MainPage.xaml.h" and "MainPage.xaml.cpp". 

MainPage.xaml.h 

// 

// MainPage.xaml.h 

// Declaration of the MainPage class. 

// 

 

#pragma once 
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#include "MainPage.g.h" 

 

namespace PDFReader 

{ 

 /// <summary> 

 /// An empty page that can be used on its own or navigated to within a Frame. 

 /// </summary> 

 public ref class MainPage sealed 

 { 

 public: 

  MainPage(); 

 

 private: 

  void OpenFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e); 

 

 private: 

  foxit::rdk::uiextensions::UIExtensionsManager^ m_uiextensions; 

 

 }; 

} 

MainPage.xaml.cpp 

// 

// MainPage.xaml.cpp 

// Implementation of the MainPage class. 

// 

 

#include "pch.h" 

#include "MainPage.xaml.h" 

 

using namespace PDFReader; 

 

using namespace Platform; 

using namespace Windows::Foundation; 

using namespace Windows::Foundation::Collections; 

using namespace Windows::UI::Xaml; 

using namespace Windows::UI::Xaml::Controls; 

using namespace Windows::UI::Xaml::Controls::Primitives; 

using namespace Windows::UI::Xaml::Data; 

using namespace Windows::UI::Xaml::Input; 

using namespace Windows::UI::Xaml::Media; 

using namespace Windows::UI::Xaml::Navigation; 

 

// The Blank Page item template is documented at https://go.microsoft.com/fwlink/?LinkId=402352&clcid=0x409 

 

MainPage::MainPage() 

{ 

 InitializeComponent(); 
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 m_uiextensions = ref new foxit::rdk::uiextensions::UIExtensionsManager(PDFViewControl); 

 

 // Associate the flyout placement of uiextensions with MainPage layout. 

 m_uiextensions->SetFlyoutPlacement(FlyoutGird); 

 

 // Set the uiextensions instance to PDF view control. 

 PDFViewControl->ExtensionsManager = m_uiextensions; 

} 

 

void PDFReader::MainPage::OpenFileButton_Click(Platform::Object^ sender, 

Windows::UI::Xaml::RoutedEventArgs^ e) 

{ 

 // Select a PDF file from a file selection dialog.   

 Windows::Storage::Pickers::FileOpenPicker^ openPicker = ref new 

Windows::Storage::Pickers::FileOpenPicker(); 

 openPicker->ViewMode = Windows::Storage::Pickers::PickerViewMode::Thumbnail; 

 openPicker->SuggestedStartLocation = 

Windows::Storage::Pickers::PickerLocationId::DocumentsLibrary; 

 openPicker->FileTypeFilter->Append(".pdf"); 

 

 concurrency::create_task(openPicker->PickSingleFileAsync()) 

  .then([this](Windows::Storage::StorageFile^ file) 

 { 

  if (file) 

  { 

   PDFViewControl->OpenDocAsync(file, ""); 

  } 

 }); 

} 

3.2 Make a UWP app in C# with Foxit PDF SDK for UWP 

This section will help you to quickly make a UWP app in C# using Foxit PDF SDK. It includes 

the following steps: 

• Create a new UWP app in C# Using Foxit PDF SDK for UWP 

• Initialize Foxit PDF SDK 

• Display a PDF document Using PDFViewCtrl 

• Build a full-featured PDF Reader Using UI Extensions Project 

3.2.1 Create a new UWP app in C# Using Foxit PDF SDK for UWP 

In this guide, we will create a new UWP project in Visual Studio 2017, and use local machine with x86 

as an example to run the project. 
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1) Create a new project in Visual Studio 2017. 

Open Visual Studio 2017, choose File -> New -> Project… to start the New Project wizard. 

Create a new Windows Universal project called "PDFReader". Please make sure to choose Visual 

C# and a blank app (See Figure 3-16).  

 

Figure 3-16 

2) Add FoxitRDK extension to References. 

In order to use FoxitRDK extension in the project, you must first add a reference to it. In the 

Solution Explorer, right-click the References node and select Add Reference… as shown in 

Figure 3-17. 

Note: If you have not installed FoxitRDK.vsix extension, please refer to "Install Foxit PDF SDK 

extension" to install it at first. 
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Figure 3-17 

In the Reference Manager dialog, select Universal Windows -> Extensions tab, check the box next 

to "FoxitRDK", and then click OK. It is shown in Figure 3-18.  

 

Figure 3-18 

3) Change the build architecture of the project. 

Click on Build -> Configuration Manager and select x86 for "Active solution platform" as 

shown in Figure 3-19. 
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Figure 3-19 

Note: There are three active solution platforms: x86, x64, and arm. You should choose the proper 

platform for the build architecture according to the system you used to run the project. For example, 

if you will run the demo in an arm device, please choose ARM for "Active solution platform". 

3.2.2 Initialize Foxit PDF SDK 

It is necessary for apps to initialize and unlock Foxit PDF SDK using a license before calling any APIs. 

The function foxit.common.Library.Initialize(sn, key) is provided to initialize Foxit PDF SDK. The trial 

license files can be found in the "libs" folder of the download package. After the evaluation period 

expires, you should purchase an official license to continue using it. Finish the initialization at the 

end of the OnLaunched function within the App.xaml.cs file. 

// Initialize Foxit PDF SDK. 

string sn = " "; 

string key = " "; 

foxit.common.ErrorCode ret = foxit.common.Library.Initialize(sn, key); 

if (ret != foxit.common.ErrorCode.e_ErrSuccess) 

   return; 

Note The value of "sn" can be found in the "rdk_sn.txt" (the string after "SN=") and the value of "key" can 

be found in the "rdk_key.txt" (the string after "Sign=").  
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3.2.3 Display a PDF document Using PDFViewCtrl 

So far, we have added FoxitRDK extension as a reference and finished the initialization of the Foxit 

PDF SDK. Now, let’s start displaying a PDF document using PDFViewCtrl with just a few lines of code. 

4) Add a PDFViewCtrl to display a PDF document. 

Open up "MainPage.xaml", update the whole file as follows: 

<Page 

    x:Class="PDFReader.MainPage" 

    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation" 

    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml" 

    xmlns:local="using:PDFReader" 

    xmlns:rdkcontrol="using:foxit.rdk" 

    xmlns:d="http://schemas.microsoft.com/expression/blend/2008" 

    xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006" 

    mc:Ignorable="d" 

    Background="{ThemeResource ApplicationPageBackgroundThemeBrush}"> 

 

    <Grid> 

        <UserControl x:Name="HostContent" Grid.Row="0"> 

            <!--Place a PDF View control.--> 

            <rdkcontrol:PDFViewCtrl x:Name="PDFViewControl"> 

                <Grid> 

                    <!--Place a button on the left-top of the view control.--> 

                    <Button Content="Open File" FontSize="20" HorizontalAlignment="Left"  

                            VerticalAlignment="Top" Click="OpenFileButton_Click"/> 

                </Grid> 

            </rdkcontrol:PDFViewCtrl> 

        </UserControl> 

         

        <!--Place a holder for uiextension flyout placement.--> 

        <Grid x:Name="FlyoutGird" Grid.Column="1" Grid.RowSpan="2" MaxWidth="300"> 

        </Grid> 

    </Grid> 

</Page> 

Here, we add a button with a click event "OpenFileButton_Click" to open a PDF document, and add 

a PDFViewCtrl to display the PDF document. 

5) Implement the "OpenFileButton_Click" function. 

Open up "MainPage.xaml.cs", implement the "OpenFileButton_Click" function as follows: 

private async void OpenFileButton_Click(object sender, RoutedEventArgs e) 

{ 

// Select a PDF file from a file selection dialog.   
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    var fileOpenPicker = new Windows.Storage.Pickers.FileOpenPicker(); 

    fileOpenPicker.ViewMode = Windows.Storage.Pickers.PickerViewMode.Thumbnail; 

    fileOpenPicker.SuggestedStartLocation = Windows.Storage.Pickers.PickerLocationId.DocumentsLibrary; 

    fileOpenPicker.FileTypeFilter.Add(".pdf"); 

 

    // Open a PDF file asynchronously. 

    Windows.Storage.StorageFile file = await fileOpenPicker.PickSingleFileAsync(); 

    if (file == null) 

         return; 

    foxit.common.ErrorCode errCode = await this.PDFViewControl.OpenDocAsync(file, ""); 

} 

Inside the "OpenFileButton_Click" function, get a PDF document from the file picker, and call 

OpenDocAsync interface to display the PDF document.  

6) Click on Local Machine to build and run the project. The screenshot of the project is shown in 

Figure 3-20. 

 

Figure 3-20 

Click on Open File to choose and open a PDF document. For example, we choose the 

"sample.pdf" in the "Samples\FunctionDemo\TestFiles" folder, and then it will be displayed as 

shown in Figure 3-21. 
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Figure 3-21 

Note: If you cannot open PDF files, you should add File Type Associations Declarations in the 

"Package.appxmanifest" file. 

Double click Package.appxmanifest in the project, find Declarations, and add a File Type 

Associations as shown in Figure 3-22. 

 

Figure 3-22 

Now, we have finished displaying a PDF document using PDFViewCtrl. At that time, the PDFReader 

app is just a very basic PDF document viewer. You can only view or zoom in/out the PDF document. 

If you want to build a full-featured PDF Reader app, just follow the steps in the next section. 
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3.2.4 Build a full-featured PDF Reader Using UI Extensions Project 

The UI Extensions project contains all of the UI implementations including the basic UI for app and 

the feature modules UI. Hence, building a full-featured PDF Reader is getting simpler and easier. 

Let's try it just now. 

1) Add "UIExtensions" project in the "libs" folder of the download package to the solution. 

In the solution explorer, right-click on the PDFReader solution and select Add -> Existing 

Project…, navigate to the folder where the "foxitpdfsdk_7_0_2_uwp.zip" was unzipped, open the 

"UIExtensions" folder in the "libs" folder, then select "UIExtensions.vcxproj". (See Figure 3-23 and 

Figure 3-24) 

 

Figure 3-23 
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Figure 3-24 

After adding the "UIExtensions" project, the solution should look like Figure 3-25. 

 

Figure 3-25 

2) Add "foxit.rdk.uiextensions" project as a reference used by PDFReader. Do this in a similar way 

to how we added FoxitRDK extension. 
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In the Solution Explorer, in the PDFReader project, right-click the References node and select 

Add Reference…. In the Reference Manager dialog, select Projects -> Solution tab, find 

"foxit.rdk.uiextensions" in the list, check the box next to it and then click OK. (See Figure 3-26) 

 

Figure 3-26 

3) Build "foxit.rdk.uiextensions" project. Right-click the project, select Build. 

4) Add SDK resources to the project.  

In the Solution Explorer, click the PDFReader project, find the Resources folder under 

"libs\UIExtensions" folder of Foxit PDF SDK for UWP package, then drag and drop the Resources 

folder to the PDFReader project.  After adding, the PDFReader project should look like Figure 

3-27. 
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Figure 3-27 

5) Instantiate a UIExtensionsManager object and set it to PDFViewCtrl. 

Open up "MainPage.xaml.cs", instantiate a UIExtensionsManager object and set it to PDFViewCtrl 

in the constructor of MainPage: 

public MainPage() 

{ 

 this.InitializeComponent(); 

 

 foxit.rdk.uiextensions.UIExtensionsManager m_uiextensions = new 

foxit.rdk.uiextensions.UIExtensionsManager(this.PDFViewControl); 

   

 // Associate the flyout placement of uiextensions with MainPage layout. 

 m_uiextensions.SetFlyoutPlacement(this.FlyoutGird); 

   

 // Set the uiextensions instance to PDF view control. 

 this.PDFViewControl.ExtensionsManager = m_uiextensions; 

} 

6) Click on Local Machine to build and run the project.  

Click on Open File to choose and open a PDF document. For example, we choose the 

"sample.pdf" in the "Samples\FunctionDemo\TestFiles" folder, and then it will be displayed as 

shown in Figure 3-28. 
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Figure 3-28 

Now, a full-featured PDF Reader app which is similar to the C# demo (PDFViewer) has been built. 

Feel free to try the features. 

The "foxit.rdk.uiextensions" project coded by Visual C++ has implemented the basic UI for app and 

the feature module UI, so that if you want to customize the UI for styling the appearance as desired, 

you should modify the code in the UIExtensions project directly with Visual C++.  

Complete Program 

This section shows the whole update of "MainPage.xaml.cs". 

MainPage.xaml.cs 

using System; 

using System.Collections.Generic; 

using System.IO; 

using System.Linq; 

using System.Runtime.InteropServices.WindowsRuntime; 

using Windows.Foundation; 

using Windows.Foundation.Collections; 

using Windows.UI.Xaml; 

using Windows.UI.Xaml.Controls; 

using Windows.UI.Xaml.Controls.Primitives; 

using Windows.UI.Xaml.Data; 

using Windows.UI.Xaml.Input; 

using Windows.UI.Xaml.Media; 

using Windows.UI.Xaml.Navigation; 
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// The Blank Page item template is documented at https://go.microsoft.com/fwlink/?LinkId=402352&clcid=0x409 

 

namespace PDFReader 

{ 

    /// <summary> 

    /// An empty page that can be used on its own or navigated to within a Frame. 

    /// </summary> 

    public sealed partial class MainPage : Page 

    { 

        public MainPage() 

        { 

            this.InitializeComponent(); 

 

            foxit.rdk.uiextensions.UIExtensionsManager m_uiextensions = new 

foxit.rdk.uiextensions.UIExtensionsManager(this.PDFViewControl); 

   

            // Associate the flyout placement of uiextensions with MainPage layout. 

            m_uiextensions.SetFlyoutPlacement(this.FlyoutGird); 

   

            // Set the uiextensions instance to PDF view control. 

            this.PDFViewControl.ExtensionsManager = m_uiextensions; 

        } 

 

        private async void OpenFileButton_Click(object sender, RoutedEventArgs e) 

        { 

            // Select a PDF file from a file selection dialog.    

            var fileOpenPicker = new Windows.Storage.Pickers.FileOpenPicker(); 

            fileOpenPicker.ViewMode = Windows.Storage.Pickers.PickerViewMode.Thumbnail; 

            fileOpenPicker.SuggestedStartLocation = Windows.Storage.Pickers.PickerLocationId.DocumentsLibrary; 

            fileOpenPicker.FileTypeFilter.Add(".pdf"); 

 

            // Open a PDF file asynchronously. 

            Windows.Storage.StorageFile file = await fileOpenPicker.PickSingleFileAsync(); 

            if (file == null) 

                return; 

            foxit.common.ErrorCode errCode = await this.PDFViewControl.OpenDocAsync(file, ""); 

        } 

    } 

}   
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4 Technical Support 

Reporting Problems 

Foxit offers 24/7 support for its products and are fully supported by the PDF industry’s largest 

development team of support engineers. If you encounter any technical questions or bug issues 

when using Foxit PDF SDK for UWP, please submit the problem report to the Foxit support team at 

http://tickets.foxitsoftware.com/create.php. In order to better help you solve the problem, please 

provide the following information: 

• Contact details 

• Foxit PDF SDK product and version 

• Your Operating System and IDE version 

• Detailed description of the problem 

• Any other related information, such as log file or error screenshot 

Contact Information 

You can contact Foxit directly, please use the contact information as follows: 

Foxit Support: 

• http://www.foxitsoftware.com/support/ 

Sales Contact:  

• Phone: 1-866-680-3668 

• Email: sales@foxitsoftware.com 

Support & General Contact: 

• Phone: 1-866-MYFOXIT or 1-866-693-6948 

• Email:  support@foxitsoftware.com 

http://tickets.foxitsoftware.com/create.php
http://www.foxitsoftware.com/support/
mailto:sales@foxitsoftware.com
mailto:support@foxitsoftware.com
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